Platform Outage
Incident Report for HSI Platform
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 21:16 UTC
Investigating
HSI is currently experiencing an outage. We are actively working to fix the issue and apologize for the inconvenience. We will update as soon as possible
Posted Jul 18, 2024 - 21:09 UTC
This incident affected: HSI Platform (Chemical Management, HSI LMS (Pillar)) and SMS (DoneSafe).