Students cannot access their profile in eClarus MSHA site
Incident Report for HSI Platform
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 15:34 UTC
Investigating
We are currently investigating the issue where students cannot access their MSHA profile. Thank you for your patience.
Posted Nov 08, 2024 - 14:24 UTC
This incident affected: LMS - eClarus.